Menu Bar (D2000 GrEditor)

Menu Bar (D2000 GrEditor)

GrEditor environment - menu bar

The menu bar includes the items:

System menu


The menu System allows to log on and log off for a user, create, open close save, delete pictures and exit the process D2000 GrEditor.

System menu
System menu

Logon

Logon for work in the process D2000 GrEditor.

Logoff

Logoff after finishing work with the process D2000 GrEditor.

Window size

Setting the size of the active window according to resolution.

New Picture...

Create a new picture.

Open Picture...

Open a picture.

Close

Close the opened picture.

Save

Save the opened picture.

Save As...

Save the opened picture with another name.

Save All

Save all opened pictures.

Delete Picture

Delete the selected picture.

Print...

Print edited picture.

[History]

List of last edited pictures. The list can contain at most eight (8) pictures.

Exit

Exit GrEditor.

Edit menu


The menu Edit allows performing some basic edit actions.

gr_edit_menu.png

Undo

Undo - cancel last performed action.

Redo

Redo - repeated execution of the last action cancelled by the action Undo.

Cut

Cut out a selected object (selection of objects).

Copy

Copy the selected object (selection of objects).

Paste

Insert the selected object (selection of objects) from the ClipBoard into the edited picture.

Picture script...

Edit the picture script.

Local variables...

Edit the picture's local variables.

Tab order...

Set the order of windows controls.

Picture structure…

Open the picture structure inspector.

Connections...

Open the list of object connections in the picture.

Filters

Filtrate the visible objects in pictures depending on some attribute of these objects.

Clear Picture...

Delete all objects in the edited picture.

Settings menu


The menu Settings allows you to set up the parameters of the process D2000 GrEditor and the parameters of the edited picture.

Settings menu
Settings menu

Gr.Editor settings...

Set up the D2000 GrEditor parameters.

Picture settings ...

Set up the picture parameters (size, background color, background bitmap, pattern, etc.).

XML Export settings ...

Settings for XML export of the objects.

XML Repository settings..

Settings for XML Repository.

Configuration Gr menu


Using the items of the menu Configuration it is possible to create, modify and delete the items stated below. Transformation palette, System Messages and Log Database are being configured through the D2000 CNF process.

Configuration menu
Configuration menu

Color palettes...

Create, modify and delete color palettes.

Display palettes...

Create, modify and delete display palettes.

Bitmap palettes...

Create, modify and delete bitmap palettes.

Extended palettes...

Create, modify and delete extended palettes.

Text fonts...

Create, modify and delete text fonts.

Bitmaps...

Add, update and delete bitmaps.

Dictionary generation

Open the dictionary generation dialog for selected objects.

Configuration D2000 menu


Using the items of the menu Configuration D2000 it is possible to create, modify and delete the items stated below.

Configuration menu
Configuration menu

List of objects

The selection window involves the list of the D2000 System objects, which may be categorized according to object type, membership in the logical groups and simple filter.

Naming

Definition of prefixes and suffixes for the objects of the D2000 System. You can find more information in the chapter Naming.

Log Database

Allows configuring the log database parameters.

System texts...

Allows changing the names of system messages.

Transformation palettes...

Create, modify and delete transformation palettes.

Dictionary

Dictionary enables one to define the languages and keywords and texts that are assigned to the particular keywords.

History watch

Enables to browse the object modification history.

ESL Diagnostic pack

Shows detailed information about the running instances of objects of Event and Picture type.

CNF...

Edit object in the process D2000 CNF.

XML Import

Activates XML Import of the objects through the import dialog window.

Utils menu


The menu Utils contains tools for working with bitmaps.

If at least one .DLL file for importing external pictures in different graphic formats is placed in the subdirectory \Bin of the program files\ directory, the menu Utils will contain the item Imports. Nowadays, the D2000 systems provide partial support for importing Autocad-DXF format files and there is also a defined interface for writing import .DLL files (description of the interface is supplied on demand).

Imports

Import pictures in different graphic vector formats.

Note 1: When importing, the picture, to which the other pictures should be imported, must be opened.

Note 2:  Import drivers for the process D2000 GrEditor are .dll files and their names must begin with the prefix Imp_. They must be placed in the subdirectory \Bin of the program files directory. It is possible to add other drivers during the process run.

Window menu


The menu Window allows you to arrange the windows of pictures opened on the GrEditor desktop.

Window menu
Window menu

Cascade

All windows opened on the desktop will be arranged in a cascade.

Tile Horizontally

All windows opened on the desktop will be arranged one above another (x-size of the windows will be maximized).

Tile Vertically

All windows opened on the desktop will be arranged one next to another (y-size of the windows will be maximized).

Close All

Close all windows opened on the desktop.

[Opened pictures]

The bottom part of the menu contains the names of all windows opened on the desktop. An active window is a window with the symbol

before its name.

Help menu


The menu Help allows opening the D2000 html Help (the item Contents) and dialog box that provides information about status and range of license.

Help menu
Help menu