Menu Bar (Work with D2000 HI)

Menu Bar (Work with D2000 HI)

HI process environment - Menu bar

The Main menu bar can contain of the following menus:

Presence and contents of the menus depend on the access rights of the user, on the configuration and status of the process D2000 HI. All the basic menus are described  in the text below.

System menu


The System menu allows to log on/off an user, change password, printing and exiting the process D2000 HI. It contains the following items: Logon, Logoff, Change Password, Send Message, Settings, Print, Modal HI and Exit.

System menu
System menu

Logon

Logon to operate with the process D2000 HI.

Logoff

Logoff after finishing your work with the process D2000 HI.

Change Password

Change user's logon password.

Window size

Setting a size of active window according to resolution.

Send Massage

Send message to other consoles.

Console Preferences

Opens the Console Preferences dialog box to configure the HI settings for all users on given computer.

User Preferences

Opens the User Preferences dialog box to customize the HI settings for given user.

XML Export settings...

Settings for XML export of the objects.

Print

Print graphic information windows (pictures, graphs).

Modal HI

Enable / disable the modal mode of the process D2000 HI. If process D2000 HI is in the modal mode, you are not able to minimize and resize Hi process window and also switch to other applications. Modal HI allows to switch only to applications started as external tools.

Exit

Exit HI process.

Open menu


The Open menu is used to open graphic information windows, display alarms, the archive and log database. It contains the items: Compositions, Pictures, Graphs, Reports, Alarms, Browser, Logging, Archives, Time channels and Structures.

Open menu
Open menu

Compositions

Open a composition of graphic information windows.

Pictures

Open a picture.

Graphs

Open a graph.

Alarms

Open the list of alarms.

Browser

Open Browser.

Logging

Browse the log database.

Archives

Browse the archive of historical values.

Time Channels

Browse time channels.

Structures

Open a structured variable (Structured variables item ) or database table (Database table item).

User menu


The User menu contents is given at user's configuration by the reference to an object of HI menu type which allows to open defined set of pictures, graphs and reports.

Configuration menu


The Configuration menu is used to configure graphic information windows. The menu contains the following items: Compositions, Graphs, User macros and External tools.

Configuration menu
Configuration menu

Compositions

Create, edit and delete compositions of graphic information windows - the topic Configuration of compositions.

Graphs

Create, edit, and delete graphs - see the topic Graph configuration.

User Macros

Define, edit and delete user macros - see the topic Configuration of User macros.

External Tools

Define, edit and delete external tools - external applications started from the process D2000 HI - see the topic Configuration of External tools.

Tools menu


The menu is available only if at least one external tool with the Also in menu parameter checked has been defined. The Tools menu allows to start individual external tools. External tool - application is started by selecting from this menu or by keyboard shortcuts SHIFT+F1 to SHIFT+F8.

Tools menu
Tools menu

For more information see the topic Configuration of External tools.

Window menu


The Windows menu contains the items Cascade, Tile Horizontally, Tile Vertically, Close All and the list of windows opened on Hi process desktop.

Window menu
Window menu

Cascade

All windows opened on the desktop of the process D2000 HI are automatically arranged in a cascade.

Tile Horizontally

All windows opened on the desktop of the process D2000 HI are automatically arranged horizontally.

Tile Vertically

All windows opened on the desktop of the process D2000 HI are automatically arranged vertically.

Close All

Close all windows opened on the desktop of the process D2000 HI (including dialog pictures).

Help menu


The Help menu contains the D2000 HI Help, About HI and License items. If a user has an administration rights, in the menu there is other item - System information. For other users this item is accessible through ALT+F1.

Help menu
Help menu

D2000 HI Help

Opens the on-line HI process Help.

System information

Opens the dialog box that contains the path to the logs of D2000 System processes.

About HI

Shows the D2000 HI info - version, release.

License

Shows the information about range and state of a license.

Related pages:

HI environment